Stock Model Fixer


Автор MastaMan
Обновлено Декабрь 15, 2020
English и Русский

Оглавление

Описание

Stock Model Fixer мощный инструмент для оптимизации и подготовки моделей, перед добавлением в основную сцену проекта. Вы можете также исправить и оптимизировать модели в текущей сцене.

Данный скрипт незаменимый при использовании моделей с 3ddd/3dsky, cgtrader, hotpies и других ресурсов.

Скачать Stock Model Fixer

Возможности

  • Удаление анимационных ключей
  • Отключение BackfaceCull свойства
  • Включение Renderable свойства
  • Resolve и Relink текстур
  • Удаление пустых объектов
  • Удаление пустых слоев
  • Очистка MultiMaterial
  • Отобразить все спрятанные объекты/полигоны
  • Быстрое копирование/вставка выбранных моделей между окнами 3Ds Max (даже разных версий)
  • Работа с TurboSmooth (Добавить, Удалить, Выбрать, Iters. на 0)
  • Адаптация модели под размеры
  • Исправление геометрии (Reset XForm, Detach Trick, Box Trick, Snapshot)
  • Группировка/Разгруппировка
  • Быстрая установка центр масс (Pivot Point)
  • Перемещение модели в центр сцены
  • Attach выделенных объектов
  • Переименование: текстур, материалов, объектов, групп
  • Проверка на ошибки (xView, AssetTracking, Clay Mode)
  • Копирование текстур в папку проекта
  • Мгновенные обновления
  • Подсказки
  • Мультиязычный интерфейс
Краткий обзор всех возможностей скрипта в этом видео:

Видео демонстрация возможностей Stock Model Fixer

Как использовать

Разархивируйте модель, которую вы скачали, в любом месте на жёстком диске.
Убедитесь, что вы извлекли все файлы и текстуры.
Рекомендуется для удобства, открыть два окна 3Ds Max. Одно - для вашей текущей сцены проекта, другое - для подготовки модели.

  • Создайте новую сцену и откройте модель. Затем нажмите кнопку Применить (Apply) во вкладке File в скрипте Stock Model Fixer. Все отмеченные опции из "Применить к текущей сцене" (Apply to current scene) будут применены к текущей сцене!
  • Во вкладке Tools, если необходимо, сделайте Box Trick, Detach Trick, Snapshot, Reset XForm, чтобы исправить битую геометрию модели.
  • Во кладке Textures, укажите путь сохранения текстур (Копировать текстуры в папку) (к примеру папка с текстурами вашего проекта) и нажмите Копировать текстуры (Copy Textures). Все текстуры модели будут перенесены в указанное место.
  • Скопируйте и вставьте модель при помощи CopyTo/PasteFrom.
  • Готово!
Посмотрите это видео с примером использования данного скрипта:

Пример использования Stock Model Fixer


Stock Model Fixer имеет множество инструментов для оптимизации и подготовки моделей. Более подробно о каждой вкладке читайте ниже.

Установка

В новых версиях Stock Model Fixer используется Universal Installer, который поможет вам с установкой, а также создаст кнопки в Main Toolbar и Quad Menu. Все сделано, чтобы вы прилагали минимум усилий и не теряли драгоценное время.

Шаг 1

stock model fixer install scripting run script
Loading...
Запустите инсталлятор, просто перетяните (Drag&Drop) файл StockModelFixer.mzp во Viewport программы Autodesk 3Ds Max.
Или выполните запуск StockModelFixer.mzp при помощи выпадающего меню Scripting → Run Script.

Весь процесс установки есть в этой видео инструкции. В качестве примера используется другой скрипт (Prune Scene), но процесс абсолютно идентичный и для Stock Model Fixer!

Установка на примере Prune Scene (Видео)

Шаг 2

После запуска инсталлятора вы увидите следующее окно:
installation wizard s0
Loading...
Выберите подходящий для вас язык интерфейса, нажмите Далее (Next)

Шаг 3

installation wizard s1
Loading...
Прочитайте лицензионное соглашение и согласитесь с ним, нажмите Далее (Next).
(Полная информация о Политике безопасности, Условии использования и Лицензионном соглашении, есть на официальном сайте https://3dground.net. Используя данный скрипт, или любую его часть, вы автоматически соглашаетесь со всеми условиями!)

Шаг 4

installation wizard s2
Loading...
На этом этапе, вы можете настроить параметры установки. К примеру где создавать кнопку в интерфейсе (Main Toolbar, Quad Menu, Main DropDown Menu).
Мы рекомендуем оставлять все опции по-умолчанию и нажать Далее (Next)
Ниже будет описание, что делает каждая опция, если вы захотите что-либо изменить.

Tool Bar (Recommended) - установка кнопки с иконкой на главной панели инструментов.
Main DropDown Menu - создание нового выпадающего меню с названием 3DGROUND рядом с выпадающим меню Help и подпунктом Stock Model Fixer. Если будут установлены другие скрипты с этого сайта, они будут добавляться в выпадающее меню 3DGROUND.
Quad Menu - создание нового пункта меню Stock Model Fixer в QuadMenu.

Использовать HiDPI иконки (Use HiDPI icons) - использовать векторные иконки (SVG) для мониторов большого разрешения. Если ваш 3Ds Max выше версии 2018, где есть официальная поддержка мониторов с большим разрешением, вы можете включить данную опцию. Иконки будут работать для обычных мониторов, так и мониторов с большей плотностью пикселей.
(Стоит учесть, что по непонятным причинам, у некоторых пользователей (около 15%) могут не отображаться HiDPI иконки. Поэтому по-умолчанию опция выключена - Нет (No). Вы можете включить эту опцию, но если у вас пропадет иконка скрипта в интерфейсе, просто переустановите скрипт с настройкой по-умолчанию - Нет (No))
Опции установки/удаления (Setup Options) - вы можете выбрать Установить (Install) или Удалить (Remove) скрипт.

Шаг 5

installation wizard s3
Loading...
На данном этапе установщик копирует все файлы и создает пункты меню. Вам понадобиться нажать Да (Yes), если установщику будет недостаточно прав для выполнения копирования. Смотрите скриншот ниже:
uac
Loading...
Если вы нажмете Нет (No), - нет никаких гарантий, что скрипт будет работать корректно и будут скопированы все файлы!

Шаг 6

installation wizard s4
Loading...
Если установка прошла успешно, вы увидите следующее окно. Нажмите Готово (Finish) для выхода из установщика. 
Вы можете теперь запустить скрипт из панели инструментов Main Toolbar или выпадающего меню 3DGROUND.
stock model fixer toolbar buttons
Loading...
Примечание!
В зависимости от настроек, выбранных при установке, данные иконки на скриншоте могут не появится в интерфейсе.

Удаление

Запустите инсталлятор и следуйте инструкциям. Подробнее смотрите раздел Установка - Шаг 1, Шаг 2, Шаг3.
installation wizard remove
Loading...
На этапе выбора опций установки, выберите Удалить (Remove), подробнее смотрите скриншот выше. Нажмите Далее (Next) и следуйте инструкциям.

В процессе удаления, если установщику будет недостаточно прав, вам понадобиться нажать Да (Yes), в окне UAC, смотрите скриншот ниже:
uac
Loading...
После успешного удаления, вы увидите окно:
installation wizard uninstall success
Loading...

Мультиязычность

stock model fixer multilanugage
Loading...
В новых версиях Stock Model Fixer, добавлена поддержка разных языков интерфейса.
На данный момент поддерживаются следующие языки: English, Russian, Ukrainian, Polish, Vietnamese.

Вы можете выбрать язык интерфейса во время установки Stock Model Fixer или после его запуска.

Выберите подходящий язык в выпадающем меню Language и интерфейс мгновенно будет отображен на выбранном языке, без необходимости повторно открывать скрипт.

Список языков составлен не случайным образом. Добавлены именно те языки, регионы которых сделали наибольшее число покупок. 
Если вы хотите видеть Stock Model Fixer на родном языке, купите лицензию и поддержите сам скрипт, возможно ваш язык будет включен в следующую версию?!

Не исключены грамматические ошибки и опечатки в переводе, пишите в комментариях, если найдете неточности. 
Или же, мы можем предоставить вам все необходимы инструменты, для редактирования языкового файла!

Вкладка File

stock model fixer tab file
Loading...
Откройте модель в новой сцене, нажмите кнопку Применить (Apply), что бы все отмеченные опции в "Применить к текущей сцене" (Apply to current scene) были применены.

Удалить ключи анимации (Remove Animation Keys) - удаляет все ключи анимации. Обычно анимация не нужна и эта опция включена по-умолчанию.
Отключить свойство BackFace Cull (Disable BackFace Cull Property) - отключает BackFace Cull свойство всем объектам в сцене. Это ускоряет работу Viewport.
Включить Renderable свойство (Enable Renderable Property) - включает Renderable в свойствах для всех объектов в сцене. Довольно часто попадаются такие модели на 3D стоках, в которых отключено это свойство и заметить это можно только на рендере.
Resolve и Relink текстур (Resolve and Relink Textures) - помогает найти текстуры в папках и подпапках модели и автоматически назначить новые пути.
Удалить пустые объекты (Remove Empty Objects) - удаляет объекты с 0 количеством полигонов, пустые группы и Particle View объекты.
Удалить все слои (Remove All Layers) - удаляет все слои в сцене и переносит все объекты в 0 слой (0 default). Если вы отключите эту опцию, нежелательные и пустые слои могут попасть в вашу основную сцену проекта и испортить иерархию.
Очистить Multimaterial (Clean Multimaterial) - удаляет неиспользуемые sub-материалы.
Показать все (Объекты/Полигоны) (Unhide All (Objects/Polys)) - делает видимыми все объекты и полигоны объектов.

Раздел CopyTo/PasteFrom

CopyTo - копирует выбранные объекты.
PasteFrom - вставляет скопированные объекты.
Важно!
Какую бы вкладку вы не открыли, CopyTo/PasteFrom раздел будет доступен всегда.
Копирование и вставка объектов работает по тому-же принципу, что и бесплатный скрипт "CopyTo", и полностью совместимо с ним.


CopyTo/PasteFrom - работает между сценами, между разными окнами 3Ds Max и даже после перезагрузки компьютера.
copyto pastefrom section
Loading...

Вкладка Tools

stock model fixer tab tools
Loading...

Turbo Smooth

stock model fixer tool tab turbo smooth
Loading...
Позволяет манипулировать TurboSmooth и MeshSmooth модификаторами, примененным к объектам.

Iterations: 0 - устанавливает итерации сглаживания на 0, и активирует Render Iters.
Таким образом, сглаживание будет видно только на рендере и будет меньшая нагрузка на Viewport.
stock model fixer tab tools turbosmooth render iters
Loading...
Выбрать (Select) - выбрать все объекты в сцене с модификатором TurboSmoot и MeshSmooth.
Добавить (Add) - добавляет модификатор TurboSmooth к выбранным объекта.
Удалить (Delete) - удаляет модификатор TurboSmooth и MeshSmooths для выбранных объектов.
Подсказка!
Удобно выбрать все объекты с модификатором TurboSmooth или MeshSmooth, затем удалить для них эти модификаторы. Через Добавить (Add) - добавить новый TurboSmooth модификатор, таким образом можно контролировать количество итераций на объектах и избавиться проблемы "висящих изолированных точек" и неправильных Smooth Groups, после сворачивания стека модификаторов.

Подгонка модели под размеры (Fit Model to Dimensions)

stock model fixer tool tab fit model to dimension
Loading...
Устанавливает размер модели по заданной оси.

Ось (Axis) - ось, относительно которой будет установлен размер модели.
Подогнать модель (Fit Model) - пропорционально изменяет масштаб модели по выбранной оси с заданным размером в сантиметрах.

Установить центр масс (Set Pivot)

stock model fixer tool tab set pivot
Loading...
Позволяет быстро установить центр масс (Pivot Point).

Низ (Bottom) - устанавливает Pivot Point по центру внизу модели. Подходит для большинства моделей, которые должны стоять на поверхности (земле).
Центр (Center) - устанавливает Pivot Point по центру выбранных объектов.
Верх (Top) - устанавливает Pivot Point по центру вверху модели. Подходит для висящих объектов, таких как светильники.

Позиция (Position)

stock model fixer tool tab position
Loading...
Перемещает выбранные объекты в центр сцены.

Установить в центр сцены (Set to Scene Center) - перенести выбранные объекты в центр сцены.

Присоединить объекты (Attach Objects)

stock model fixer tool tab attach objects
Loading...
Объединяет выбранные модели в один объект. 

Объединить выбранное (Attach Selected) - объединяет выбранные объекты в один меш. Благодаря специальным алгоритмам, эта функция работает быстрее, чем стандартные средства Attach в 3Ds Max.

Очень часто, модели со стоков, имеют множество мелких объектов объединённых в группу, или что еще хуже группы в группах, что очень негативно влияет на производительность Viewport. Объединяя выбранные модели (Attach Selected) в логические куски, к примеру модель с диваном можно объединить вместе, декор отдельно, светильники со шнурами и подставкой тоже отдельно, так вы уменьшите количество объектов и разгрузите виртуальную память.
Примечание!
Конвертируйте объекты в Mesh, это позволяет экономить до 30% виртуальной памяти!

Вкладка Renamer

stock model fixer tab renamer entities
Loading...
Помогает переименовывать для выбранного: текстуры, материалы, объекты, группы, слои.

Для начала переименования, введите Название модели (Model Name). Не ленитесь писать корректные называния.
Отметьте пункты, которые нужно переименовать и нажмите кнопку Переименовать (Rename).

Если опция Переместить модель на слой (Move Model to Layer) включена, модель будет перенесена в отдельный слой. Это удобно, если в сцене проекта, к примеру вам нужно создать 100 стульев, так будет намного удобней работать с отдельным слоем.
Подсказка!
Renamer полезен, когда в именах используются кириллические символы или используются неправильные имена.

Вкладка Check

stock model fixer tab check
Loading...

Визуальный стиль (Visual Style)

stock model fixer tab check visual style
Loading...
Переключить режим Clay (Toggle Clay Mode) - переключает режим отображения Viewport между Clay/Shaded. В режиме Clay, вы будете лучше видеть Flipped (флипнутые) нормали полигонов.

xView

stock model fixer tab check xview
Loading...
Тут собраны часто используемые xView инструменты.

Изолированные вершины (Isolated Vertices) - переключает режим отображения изолированных вершин.
Перекрывающ. полигоны (Overlapping Faces) - переключает режим отображения полигонов, которые находятся в одной плоскости (перекрывают друг-друга).
Открытые грани (Open Edges) - переключает режим отображения открытых граней.

Asset Tracking

asset tracking asset tracking dialog
Loading...
Открыть Asset Tracking (Open Asset Tracking) - открывает диалог Asset Tracking, при помощи которого вы можете посмотреть или правильно расположены текстуры.

Вкладка Textures

stock model fixer tab textures
Loading...
Этот раздел помогает скопировать текстуры для выбранных объектов или всей сцены в папку с текстурами вашего проекта.

По-умолчанию опция Relink текстур (Relink Bitmaps) включена - автоматически присваивать новые пути для скопированных текстур в материалах.

Чтобы, скопировать текстуры нажмите кнопку [...], для выбора пути с текстурами вашего проекта, затем нажмите Копировать текстуры (Copy Textures).

Система обновлений

Система автоматического обновления позволяет скачать и установить новую версию скрипта в тихом режиме.
Важно!
Обновление доступно только для тех, кто приобрел лицензионный ключ!
stock model fixer update system
Loading...
Нажмите кнопку Проверить обновления (Check For Updates).
Если свежие обновления будут доступны, вы увидите зеленый индикатор с новой версией.
update
Loading...
Нажмите Обновиться до последней версии (Update To Latest Version) и подождите несколько секунд. После успешного обновления вы увидите сообщение:
updates success
Loading...
Перезапустите Stock Model Fixer и наслаждайтесь новой версией 😊.

Лицензия

Данный скрипт распространяется по условно-бесплатной лицензии. Это означает, что вы можете использовать Stock Model Fixer абсолютно бесплатно!
Все основные функции будут доступны бесплатно, кроме функции автоматического обновления по нажатию одной кнопки Проверить обновления (Check For Updates) или других пунктов указанных в разделе "Купив лицензию", ниже.
Очень надеемся, что вы не останетесь равнодушными и прочитаете этот блок текста до конца.

К сожалению, разработка, развитие и разного рода улучшение данного программного обеспечения, невозможна без вашей поддержки, как материальной так и нематериальной. 

Помимо основных функций в скрипте добавлены: быстрые обновления, мультиязычность интерфейса, удобный установщик, хорошо описанное руководство на нескольких языках - это все благодаря вашей поддержке!
Мы очень ценим ваш вклад в развитие, будь то приобретение лицензии, репост или лайк в социальных сетях, рекомендация коллеге, обзор на видео-хостинге или форуме, советы по улучшению, ваши отзывы и другое. И мы благодарны вам за ваше неравнодушие к данному продукту!

В тоже время мы прекрасно понимаем, что не каждый может делать материальный вклад, - не имея такой возможности, к примеру будучи студентом или не получая доход от своей работы в 3Ds Max, и мы не требуем от вас этого. Поэтому, мы сделали продукт бесплатным к использованию абсолютно для всех! Мы прекрасно понимаем, неудобство подписок или зависимость лицензии от версии, или других способов, чтобы стимулировать продажи и повторные покупки - поэтому отказались от этого в пользу удобства и сделали пожизненные лицензии. 

Мы надеемся на ваше понимание и желание действительно помочь развитию нашего ресурса. Сложность разработки увеличивается с каждым новым релизом, а пожизненные низкие по стоимости лицензионные ключи не приносят сверхприбыли. Если вы хотите, чтобы проект развивался и улучшался - приобретите лицензионный ключ.

Приобретая лицензию, вы делаете не только вклад в будущее этого программного обеспечения, но и стимулируете делать другие полезные продукты. 
Ведь мы стараемся для вас 😊!
Более подробное описание, какие возможности предоставляет лицензия, читайте ниже...

Купить лицензию

Купив лицензию

  • Вы отключите модальное окно при запуске скрипта, где нужно нажимать 1, 2 или 3, чтобы его закрыть
  • Вам будут доступны пожизненные обновления
  • Вам будет доступна опция обновления по нажатию одной кнопки Проверить обновления (Check For Updates)
  • О выходе каждого крупного релиза, вы будете уведомлены по email
  • Вы поддержите автора и продолжите разработку данного скрипта
  • Вы получите полноценную поддержку
  • Вы сможете участвовать в разработке скрипта

Лицензионное соглашение

  • Это программное обеспечение доступно всем для бесплатного использования
  • Вы можете использовать практически все функции данного программного обеспечения бесплатно
  • Вы можете использовать 1 (один) лицензионный ключ максимум на 2 (два) компьютера (Дом и Работа)
  • Автор не несет никакой ответственности за возможную потерю данных на вашем компьютере или другие убытки связанные с данным программным обеспечением
  • Вы не имеете права передавать третьим лицам или сдавать в суборенду лицензионный ключ
  • Вы не имеете права получать прибыль от использования или предоставления лицензионного ключа как для получения непосредственной коммерческой или денежной, так и другой выгоды
(Данное лицензионное соглашение является выдержкой из общих правил. Более подробную информацию о Лицензионном соглашении, Политике безопасности и Условии использования вы можете найти сайте https://3dground.net. Используя данное программное обеспечение, вы автоматически соглашаетесь со всеми правилами и политиками, описанные на данном сайте.)

Лицензионное сообщение

Каждый раз, при запуске Stock Model Fixer, вы будете видеть сообщение с просьбой о покупке лицензии.
license stock model fixer
Loading...
Чтобы закрыть это окно, нажмите 1, 2 или 3.
Смотрите на надпись "Чтобы закрыть это окно нажмите #..." ("For close this window press button #...").
Закрыв данное окно, вы сможете продолжить бесплатно использовать все функции (кроме, указанных выше в разделе "Купив лицензию").
Приобретите лицензионный ключ, чтобы это окно больше не отображалось!

Покупка и использование лицензионного ключа

Для покупки лицензионного ключа, перейдите на страницу продукта:

Страница Stock Model Fixer


Или нажмите на ссылку >>Купить лицензионный ключ<< (>> Press here for buy License Key <<), в окне лицензии скрипта.
Вы будете перенаправлены на страницу оплаты.
Этот скрипт использует условно-бесплатную лицензию! Пожалуйста, приобретите лицензионный ключ для поддержки автора, чтобы продолжить разработку и поддержать сам скрипт.

Вы можете использовать лицензионный ключ максимум на 2-ух компьютерах (Дом и Работа).
Ваша лицензия будет работать постоянно, и вы будете получать пожизненные обновления!
Выберите удобный способ оплаты. Заполните правильно Имя, Фамилию и ваш email.
Важно!
Указывайте правильные данные при оформлении покупки! На указанный вами email будет отправлено сообщение с лицензионным ключом!
После оплаты, найдите ваш лицензионный ключ на указанном вами email. Найдите его и скопируйте в буфер обмена.
prune scene license on email
Loading...
Вставьте скопированный вами ключ в окно уведомления о лицензии.
stock model fixer enter license key
Loading...
Если, вы сделали все правильно, при старте скрипта вы больше не увидите сообщение о лицензии.
А, в свитке License, будет сообщение о пожизненной лицензии.
stock model fixer license success
Loading...


{{commentsMsg}}
  

Никто не оставил комментариев
{{comment.lastname}} {{comment.name}} {{comment.date}}
{{comment.text}}


ПОДПИШИСЬ НА СВЕЖИЕ НОВОСТИ

{{subscribeMsg}}