Stock Model Fixer

Updated on September 7, 2018

Index


Overview

Stock Model Fixer is a powerful tool for optimizing and preparing models downloaded from 3D stocks, before adding to your scene. Using the script, you can also optimize and correct the models already in the existing scene.

Stock Model Fixer is indispensable when using models from 3ddd/3dsky, cgtrader, hotpies and other resources.

How to work with Stock Model Fixer:

Unzip the model you downloaded from anywhere on the hard disk.
Make sure that you have extracted all the files and textures of the model.
It is most recommended to open two 3Ds Max windows, one with your scene, the other for preparing the model.

  • Create a new scene and open the model by clicking the Open Model button in the File tab in the Stock Model Fixer, so all the options from the Load Model Settings are applied.
  • In the Tools tab it is necessary to do BoxTrick, DetachTrick, Snapshot, Reset XForm of your model, to fix the broken geometry.
  • In the Textures tab, select the Texture Path to your project (Copy Textures To Folder) and click Copy Textures. All model textures will be transferred to a new location.
  • Copy and paste the model using CopyTo/PasteFrom.
  • Well done!

In Stock Model Fixer a lot of tools for optimizing and preparing the models, for more details read about each option below.

File Tab

stock model fixer file tab
Open the model using the Open Model button.
After loading the model, the Load Model Settings will be applied to it:

Remove Animation Keys - delete animation keys. Usually, animation is not needed, so the option is enabled by default.
Disable BackFace Cull Property - disable BackFace Cull for objects. This speeds up the work of Viewport.
Enable Renderable Property - turn on Rendarable for all objects. Quite often there are such models on 3D stocks - in which this option is turned off and it is possible to detect it only after the render.
Resolve And Relink Textures - allows you to find textures in a folder and subfolders of the model and automatically assign new paths.
Remove Empty Objects - removes empty objects with 0 polygons, empty groups and Particle View objects.
Remove All Layers - removes all layers in the scene with the model and moves all objects to layer 0 (default). If you disable this option, unwanted and empty layers can get in to main scene and damage the hierarchy of layers in your scene.
Clean MultiMaterial - removes unused sub-materials.
Unhide All (Objects/Polys) - displays all hidden objects and hidden polygons for objects.

CopyTo/Paste Rollout

stock model fixer copyto
CopyTo - copies the selected object(s).
PasteFrom - paste the copied object(s).

Important!

Whatever tab you open (File, Tools, Renamer, etc.), the CopyTo/PasteFrom rollout is always active.
Copying and pasting objects works on the same principle as a separate freeware script "CopyTo" (https://3dground.net/prod/copyto-2211507) and it is fully compatible with it.

Copy/Paste objects will work between scenes, between different 3Ds Max windows, and even after the computer restarts.
stock model fixer copy paste process

Tools Tab


TurboSmooth

stock model fixer turbosmooth
Allows to manipulate with the modifiers TurboSmooth and MeshSmooth.
Iterations: 0 - sets the number of smoothing Iterations to 0 and enables Render Iters.
stock model fixer turbosmooth modifier iters0
Select - selects all objects in the scene with the TurboSmooth and MeshSmooth modifiers.
Add - adds a TurboSmooth modifier to the selected objects.
Delete - removes the TurboSmooth and MeshSmooth modifiers for selected objects.

It's convenient to select objects with TurboSmooth or MeshSmooth modifiers, then delete them and apply smooth with the Add button. This way you can control the number of Iterations and when the stack collapses, you will avoid glitches - incorrect Smooth Groups or isolated vertices.

Fit Model to Dimensions

stock model fixer fit model to dimensions
Sets the model dimensions for the selected axis.

Axis - the axis relative to which the model size will be set.
Fit Model - proportionally changes the scale of the model on the selected axis with a given size in centimeters.

Geometry Fix

stock model fixer geometry fix
Corrects the broken geometry. We recommend using all the options in this group for each model being prepared.

Reset XForm - collapse the modifier stack and resets the transformation of the model.
BoxTrick - creates a box and attach the entire model geometry to the box. Then removes the polygons box. This allows to redefine the numbering vertices, and also fixes errors from Smooth Groups.
DetachTrick - detach all model polygons into a separate object. The remaining empty object deletes. This helps to fix problems with normals.
Snapshot - applies a standard tool from the 3Ds Max Main Toolbar → Tools → Snapshot and removes the old copy of the model. This completely recreates the entire structure of mesh, which helps to avoid "blowing" of geometry after MassFX and PathDeform.

Important!

Try to always apply these 4 options to the model, this will avoid a lot of errors with geometry or make prevention. If all objects in the scene are processed through Geometry Fix, your scene will work much more stable: the weight of the scene will not grow unreasonably, get rid of the shading problem and the "blowing" of geometry and reduce the number of fatal errors during the rendering.

Convert to Mesh - force converts objects to Mesh when using Reset XForm, BoxTrick, Snapshot, DetachTrick. Models converted to Mesh uses 30% less memory.
Remove Isolated/Unused Vertices - removes unused or isolated vertices.

Group

stock model fixer group
Add or remove groups for objects.

Group All - creates a group for the selected objects. This removes all old groups and subgroups.
Ungroup All - deletes all groups and subgroups for selected objects.

Set Pivot

stock model fixer set pivot
Allows you to quickly set Pivot Point.

Bottom - sets Pivot Point to the center and bottom of the selected objects. Suitable for most models that can be put on the ground.
Center - sets Pivot Point to the center of the object.
Top - sets Pivot Point in the center and at the top of the object. Suitable for hanging objects like lights.

Positon

stock model fixer position
Moves the model to the center of scene.

Set to Scene Center - places objects in the center of the scene.

Attach Objects

Combines the selected objects into one mesh.

Attach Selected - combines the selected objects into one mesh. Attach uses a special algorithm that works faster than standard tools in 3Ds Max.

Very often downloaded models have many small objects grouped together into a group, which negatively affects the performance of Viewport. By making Attach Selected by logical parts, this can greatly improve performance. There is no sense in holding different objects such as a body, a display, buttons, a logo of mobile phone, it's unlikely that you will have to separate them, but if the phone is as one object instead of a hundred small it will take up less memory!

Important!

Convert objects to Mesh, for maximum optimization of the scene.

Renamer Tab

stock model fixer renamer
Renamer allows you to rename for all or only selected objects names: textures, materials, objects.

If the Move Model to Layer option is enabled, the model will be moved to a separate layer. This is convenient if, for example, you have 500 chairs in a scene, you can easily work with them if they are in the same layer.

To rename, write the model name in Model Name. Do not be lazy to write the correct name. Check the items you want to rename and click the Rename button.

Renamer is useful for you when Cyrillic characters are used in names or incorrect names are used.

Check Tab


Visual Style

stock model fixer visual style
Toggle Clay Mode - toggles the display mode in the Viewport between Shaded/Clay. In Clay mode, you can clearly see the flipped normals of polygons.

xView

stock model fixer xview
Here are some tools from xView.

Asset Tracking

stock model fixer open asset tracking dialog
Open Asset Tracking - opens Asset Tracking dialog, in which you can check whether correct of the location of the textures.
stock model fixer asset tracking

Textures Tab

stock model fixer textures
This section helps to copy textures for selected model or all objects to the texture folder of your project.

By default, the option Relink Bitmaps is enabled - automatically assigns new paths for the copied textures.

To copy textures, click Select Path and select the path where the textures of your project are located and click Copy Textures.

Updates

updates wizard
In new version of Stock Model Fixer used Automatic Updater Wizard, which allows you to automatically download latest version and silent install it.
Update from x.x.x to y.y.y means that you can receive free updates with your license.
The version y.y.y is the maximum version to which you can update. This does not mean that this will be the next version for update!
The period of support and free updates between versions x.x.x - y.y.y is about 2-3 years!

Important!

Updates works for those who purchased the license key!

Press the button Check For Updates.
If fresh version is available you can see the green indicator Available new version: x.x.x
check for updates
Press the Update To Latest Version and wait few seconds. After success update you can see next message.
success updated
Restart the script and enjoy new version ;)

License

The Stock Model Fixer script distributed by shareware license!
Purchase Key

License agreement:

  • This software is available in free access for every user
  • You can absolutely free to use all the features of this software
  • The author assumes no liability for damage to your computer (3D Studio Max, scene, model, etc.)
  • You have no right to transfer to third parties or acquired software license key
  • You can use license key maximum on 2 computers (Home and Work)

Obtain the license:

  • You support the author
  • You support the continued development of the script
  • You turn off the notification window when you run the script
  • You will be able to participate in the development of the script
  • You can receive free updates by clicking Check For Updates

License notice

Each time the script is run, you will see a message on purchase of the license.
license window
To close this window, press the 1, 2 or 3.
See the message for close this window press #? button, which button closes the window this time.
Purchase a license key, that the window is no longer displayed!

Purchase and using a license key

To purchase a license key, go to product page:
Stock Model Fixer

and press Buy.
Or click on the Press here for buy License Key button in the license window:
buy license
You will be redirected to the payment page.
Select a comfortable payment method, enter your e-mail and click the Continue.

Important!

Fill correctly your e-mail. In this e-mail will be sent an message with a license key.
purchase page
You can use license key maximum on 2 computers!
After payment you will be redirected to the page with a license key.
Also the key will be sent to your specified e-mail.
license key
Copy the license key and paste it in the form of License Key in the notification window of the script license.
enter license key
If you did everything correctly, the notification will automatically close and no longer appear.
In rollout License, you will see information about your license.
license applied



{{commentsMsg}}
  

No one has posted a comment yet.
{{comment.lastname}} {{comment.name}} {{comment.date}}
{{comment.text}}


SUBSCRIBE TO OUR NEWSLETTER

{{subscribeMsg}}